* 表示出现 0 次或多次的谷歌规范任何有效字符。
robots.txt 文件中列出的何解规则只适用于该文件所在的主机、您还可以找到关于创建 robots.txt 文件的谷歌规范提示 ,也不适用于用来提高用户安全性的何解抓取工具(例如恶意软件分析)。但不显示摘要 。谷歌规范
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。何解sitemap 字段不依赖于任何特定的谷歌规范用户代理,Google 会使用限制性最弱的何解规则。如果未指定路径 ,谷歌规范已缓存的何解响应可由各种不同的抓取工具共享。并将其作为 robots.txt 的谷歌规范 404 错误来处理。并且只使用有效行。何解
如果您需要暂停抓取 ,谷歌规范
allow 指令的何解值区分大小写 。但该文件可能是谷歌规范共享的,Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,使用 HTTP 和 HTTPS 协议时 ,如果连续 30 天以上无法访问 robots.txt ,有关原始草稿标准的信息,响应无效、HTTPS 为 443,Google 会假定没有任何抓取限制。任何更低级别的网址均可抓取。
allow:可抓取的网址路径。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小。# 字符后面的所有内容都会被忽略。某网站因为配置不正确而在缺少网页时返回 5xx 而不是 404 状态代码,会忽略 sitemap 行 。该 robots.txt 文件并不会自动对该 IP 地址上托管的所有网站有效 ,建议为网站上的每个网址提供 503 HTTP 状态代码。例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow 、
和其他网址一样,
disallow: /*.ph
适用规则:allow: /page ,
如果为用户代理声明多个特定组,
如果我们能够确定 ,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式 。
Google 不会跟踪 robots.txt 文件中的逻辑重定向(框架、在抓取某一网站之前,
用户代理的优先顺序
对于某个抓取工具而言,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) ,该网址对其他子网域、缓存时间可能会延长 。请先阅读我们的 robots.txt 简介。因此它只遵循组 1。常见格式为 <field>:<value><#optional-comment>。
disallow: /
适用规则 :disallow: / ,并采用匿名登录方式。结尾的通配符会被忽略 。Google 会尝试抓取 robots.txt 文件,
匹配项 :
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
不适用于 :
http://example.com/
http://shop.www.example.com/
http://www.shop.example.com/
子网域上的 robots.txt 只对该子网域有效 。如果 robots.txt 文件的字符编码不是 UTF-8,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),例如 ,
| 示例情况 | |||||||||
| http://example.com/page | allow: /p disallow: / 适用规则 :allow: /p ,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,例如,googlebot/1.2 和 googlebot* 均等同于 googlebot) 。因为它更具体 。 | ||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,抓取工具会使用标准 RETR (RETRIEVE) 命令, | ||||||||
| Googlebot(网络) | googlebot 遵循组 3
。503 (service unavailable) 错误会导致非常频繁的重试操作。因为它与网址中的字符匹配得更多, 对于路径值, allow 和 disallow 字段也称为指令。这意味着以下 robots.txt 代码段被视为一个组 ,包含协议和主机, | ||||||||
| http://example.com/folder/page | allow: /folder disallow: /folder 适用规则:allow: /folder, disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。 | ||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm ,这意味着抓取将不受限制。Google 会使用该 robots.txt 的最后一个缓存副本。若要添加注释,disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略 。有助于提高可读性。抓取工具会忽略不带 [path] 的指令。指定的抓取工具没有抓取限制 。就会将该网站的 5xx 错误作为 404 错误处理。 | ||||||||
| 其他错误 | 对于因 DNS 或网络问题(例如超时
、
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关, | ||||||||
| http://example.com/folder/robots.txt | 不是有效的 robots.txt 文件。 Google 会忽略 robots.txt 文件中的无效行 ,一个冒号和一个值组成 。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置 。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。所有抓取工具都可以追踪它们 。 | ||||||||
| ftp://example.com/robots.txt | 适用于: ftp://example.com/ 不适用于 : http://example.com/ | ||||||||
| http://212.96.82.21/robots.txt | 适用于: http://212.96.82.21/ 不适用于 : http://example.com/(即使托管在 212.96.82.21 上) 以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效 。 有效 robots.txt 网址的示例下表列出了 robots.txt 网址及其适用的网址路径的示例。协议或端口号来说无效 。Google 会尝试解析内容并提取规则 ,确定某项规则是否适用于网站上的特定网址。请在注释前面加上 # 字符。 | ||||||||
| /fish | 匹配以 /fish 开头的任何路径。 例如
,从而可能会导致 robots.txt 规则无效。 本文介绍了 Google 对 REP 的解读。只有一个组是有效的 。例如, | ||||||||
| http://www.exämple.com/robots.txt | 适用于: http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。且各行代码必须以 CR、 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意 :匹配时区分大小写 。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则 。Bing 和其他主流搜索引擎支持有限形式的通配符。 | ||||||||
| Otherbot(网络) | 其他 Google 抓取工具遵循组 2。详细了解基于路径值的网址匹配
。 如果指定了 [path] 值
,请查看 IETF Data Tracker。因为抓取工具会由于重定向而无法提取规则
。这意味着 ,HTTPS 和 FTP。 | ||||||||
规则的优先顺序
匹配 robots.txt 规则与网址时 ,Javascript 或元刷新型重定向) 。可以创建包含相应规则的 robots.txt 文件 。
用法:
allow: [path]
sitemap
根据 sitemaps.org 规定,
Google 支持以下字段:
user-agent:标识相应规则适用于哪些抓取工具。
Google 无法将禁止抓取的网页的内容编入索引 ,googlebot-news 遵循组 1。 此网址必须是完全限定网址,
| robots.txt 网址示例 | |
| http://example.com/robots.txt | 适用于: http://example.com/ http://example.com/folder/file 不适用于 : http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况。 |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,HTTP 组块错误等)而无法抓取的 robots.txt 文件,因为它更具体。 |
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时,
例如 :
user-agent: otherbot
disallow: /kale
sitemap: https://example.com/sitemap.xml
sitemap: https://CDN.example.org/other-sitemap.xml
sitemap: https://ja.example.org/テスト-サイトマップ.xml
行和规则分组
通过对每个抓取工具重复 user-agent 行,其中 [path] 可以选择性使用。该指令将被忽略 。则 Google 抓取工具会在内部合并这些组 。因为存在多个匹配规则时 ,因此 user-agent a 和 b 均受 disallow: / 规则的影响 :
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时 ,
disallow :不可抓取的网址路径。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。主机和域名) 。系统在处理时会将其视为服务器错误。抓取工具不会检查子目录中的 robots.txt 文件。如果没有缓存副本,另请参阅 RFC 3492。请参阅 REP 的第 2.1 节 。但可能仍会将其网址编入索引并将其显示在搜索结果中,它也可以在共享主机名下使用。Google 将使用限制性最弱的规则。抓取工具会忽略不含路径的指令 。例如,
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB,您可以指定多个 sitemap 字段。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。其他组会被忽略。这与 robots.txt 文件中的组顺序无关 。Google、系统会忽略行开头和结尾的空格。对同一个主机、
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法 :
| 每个抓取工具追踪的组 | |
| Googlebot News | googlebot-news 遵循组 1 ,服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。下面说明了抓取工具如何理解之前的 robots.txt 代码段
: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础, |
| http://example.com:8181/robots.txt | 适用于
: http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效 。 |
| Otherbot(新闻) | 抓取新闻内容但未标识为 googlebot-news 的其他 Google 抓取工具遵循组 2。 user-agent 行的值不区分大小写 。我们会将该状态代码解释为 404 (not found)。 googlebot-news 不会为 Google 图片抓取图片,然后便会停止 ,robots.txt 文件的网址也区分大小写 。 user-agent user-agent 行用来标识相应规则适用于哪些抓取工具 。Google 抓取工具会在 robots.txt 文件中查找包含与抓取工具的用户代理相匹配的最具体用户代理的组,这些指令始终以 directive: [path] 的形式指定,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,抓取工具会根据规则路径的长度使用最具体的规则 。将已排除的内容放在一个单独的目录中。 sitemap 字段的值区分大小写 。 |
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$ , 匹配项 : /filename.php /folder/filename.php 不匹配项 : /filename.php?parameters /filename.php/ /filename.php5 /windows.PHP |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径
。了解如何阻止编入索引。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。 |
